summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Karl Ramm <kcr@1ts.org>2011-02-21 18:09:25 +0000
committerGravatar Karl Ramm <kcr@1ts.org>2011-02-21 18:09:25 +0000
commit54c14e597986834997be7ac4d3596d7584dddd27 (patch)
treec1aab1c83012d85d1164310e1b134d839e262306 /debian
parentecb21a0c71c9a3ea78c5879a0b698870ae69d1ff (diff)
The zephyr-server-krb5 init script should be it's own thing.
So it can check for a keytab rather than a srvtab. Fixes #43.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
-rw-r--r--debian/zephyr-server-krb5.init78
2 files changed, 84 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 0657b5d..f5af25d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -89,7 +89,10 @@ clean:
-rm debian/zephyr-server-krb.templates
-rm debian/zephyr-server-krb.config
-rm debian/zephyr-server-krb.postinst
- -rm debian/zephyr-server-krb5.*
+ -rm debian/zephyr-server-krb5.README.Debian \
+ debian/zephyr-server-krb5.docs debian/zephyr-server-krb5.files \
+ debian/zephyr-server-krb5.postinst debian/zephyr-server-krb5.postrm \
+ zephyr-server-krb5.templates
-rm debian/zephyr-server-krb45.*
-rm debian/libzephyr4-krb.files debian/libzephyr4-krb5.files debian/libzephyr4-krb45.files
@@ -133,12 +136,12 @@ binary-arch: build install
cp debian/zephyr-server.$$file debian/zephyr-server-$$dir.$$file; \
done; \
done
- for file in config; do \
+ for file in config init; do \
for dir in $(filter-out krb5,$(VARIETALS)); do \
cp debian/zephyr-server.$$file debian/zephyr-server-$$dir.$$file; \
done; \
done
- for file in README.Debian docs init postrm; do \
+ for file in README.Debian docs postrm; do \
for dir in $(filter-out krb,$(VARIETALS)); do \
cp debian/zephyr-server-krb.$$file debian/zephyr-server-$$dir.$$file; \
done; \
diff --git a/debian/zephyr-server-krb5.init b/debian/zephyr-server-krb5.init
new file mode 100644
index 0000000..eaf1cc8
--- /dev/null
+++ b/debian/zephyr-server-krb5.init
@@ -0,0 +1,78 @@
+#! /bin/sh
+#
+# skeleton example file to build /etc/init.d/ scripts.
+# This file should be used to construct scripts for /etc/init.d.
+#
+# Written by Miquel van Smoorenburg <miquels@cistron.nl>.
+# Modified for Debian GNU/Linux
+# by Ian Murdock <imurdock@gnu.ai.mit.edu>.
+#
+# Version: @(#)skeleton 1.8 03-Mar-1998 miquels@cistron.nl
+#
+# This file was automatically customized by dh-make on Mon, 4 Dec 2000 05:28:22 -0500
+
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/sbin/zephyrd
+NAME=zephyrd
+DESC="zephyr server"
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ if test ! -f /etc/zephyr/krb5.keytab
+ then
+ echo 'You need to get a keytab before the kerberized zephyr server will'
+ echo 'function correctly. Get a keytab for zephyr/zephyr and put it in'
+ echo 'the file "/etc/zephyr/krb5.keytab".'
+ exit 0
+ fi
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --quiet --exec $DAEMON
+ echo "$NAME."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --oknodo --stop --quiet --exec $DAEMON
+ echo "$NAME."
+ ;;
+ restart)
+ #
+ # If the "reload" option is implemented, move the "force-reload"
+ # option to the "reload" entry above. If not, "force-reload" is
+ # just the same as "restart".
+ #
+ echo -n "Restarting $DESC: "
+ start-stop-daemon --oknodo --stop --quiet --exec $DAEMON
+ sleep 1
+ start-stop-daemon --start --quiet --pidfile \
+ /var/run/$NAME.pid --exec $DAEMON -- $zhm_args
+ echo "$NAME."
+ ;;
+ reload|force-reload)
+ echo -n "Telling $NAME to reload..."
+ start-stop-daemon --stop --signal HUP --exec $DAEMON
+ echo done.
+ ;;
+ *)
+ N=/etc/init.d/$NAME
+ echo "Usage: $N {start|stop|restart|reload|force-reload}" >&2
+ # echo "Usage: $N {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
+
+### BEGIN INIT INFO
+# Provides: zephyrd
+# Required-Start: $syslog $network
+# Required-Stop: $syslog
+# Should-Stop: $network
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: Start the zephyr server.
+# Description: Start the zephyr server.
+### END INIT INFO