summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2019-12-03 09:31:00 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2019-12-03 09:51:28 -0500
commitaa8af5bb174bd392249eb2d30f23ed04ebc8b158 (patch)
tree3fb9bb06012581c629aab5ff82ac508362a57819 /debian
parent22a59d2d8b48cb2762362bd71e24293a53bca09a (diff)
debian: Enable seccompHEADmaster
Commit 22a59d2d8b48cb2762362bd71e24293a53bca09a added basic seccomp support to zhm. Since zhm currently runs as root and handles network traffic, any sandboxing we can get is a good idea. Take a dependency on libseccomp-dev and enable seccomp support for zhm. This breaks building on kFreeBSD, but this package doesn’t currently build there anyway, so it’s not making things any worse.
Diffstat (limited to 'debian')
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules3
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index bf03797..d1df79d 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,8 @@ Build-Depends: debhelper (>= 5), libc-ares-dev, libkrb5-dev (>= 1.2.2-4),
comerr-dev, ss-dev, libreadline-dev | libreadline5-dev,
libx11-dev, libxt-dev, x11proto-core-dev, libncurses5-dev,
bison, libhesiod-dev, autotools-dev, python (>= 2.5), python-central,
- autoconf, libtool, automake, git-core | git, devscripts
+ autoconf, libtool, automake, git-core | git, devscripts,
+ libseccomp-dev
Build-Conflicts: autoconf2.13
Standards-Version: 3.9.2.0
Homepage: http://zephyr.1ts.org/
diff --git a/debian/rules b/debian/rules
index 8f575bb..daed056 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,8 @@ PACKAGES:=-plibzephyr4 -pzephyr-clients -pzephyr-server -plibzephyr-dev -plibzep
export DH_OPTIONS
CONFIGURE_ROOT=--prefix=/usr --mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info --sysconfdir=/etc --datadir=/etc \
- --with-cares=/usr --with-hesiod=/usr --enable-cmu-zwgcplus
+ --with-cares=/usr --with-hesiod=/usr --with-seccomp=/usr \
+ --enable-cmu-zwgcplus
CONFIGURE_krb5=--with-krb5=/usr
CONFIGURE_krb45=--with-krb4=/usr --with-krb5=/usr
CONFIGURE_krb=--with-krb4=/usr