summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Karl Ramm <kcr@1ts.org>2011-10-29 22:11:35 -0400
committerGravatar Karl Ramm <kcr@1ts.org>2011-10-29 22:11:35 -0400
commitcfe0813b910f5f2a08efe9a5ccca4d083216a0c5 (patch)
treebde6f95ed9c6eed31e7e411b21ad08726fd04bb7 /configure.ac
parent5ed89738ffdb2065e7e0a2a002763eb9b1d5ea4e (diff)
tweak configure/makefiles so we can build with or without ss
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 10 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 0442eb7..50f7f4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,18 +214,21 @@ fi
AC_ARG_WITH(ss,
[ --with-ss=PREFIX Specify location of ss (requires com_err)],
- [ss="$withval"], [ss=yes])
+ [ss="$withval"], [ss=maybe])
if test "$ss" != no; then
- if test "$ss" != yes; then
+ if test "$ss" != yes -a "$ss" != maybe; then
CPPFLAGS="$CPPFLAGS -I$ss/include"
LDFLAGS="$LDFLAGS -L$ss/lib"
fi
- AC_CHECK_LIB(ss, ss_perror, SS_LIBS="-lss -lreadline -lcurses",
- [AC_MSG_ERROR(ss library not found)], -lcom_err -lreadline -lcurses)
- AC_SUBST(SS_LIBS)
-else
- AC_MSG_ERROR(This package requires ss.)
+ AC_CHECK_LIB(ss, ss_perror,
+ [SS_LIBS="-lss -lreadline -lcurses"
+ AC_DEFINE(HAVE_SS, 1, [Define if we are building with the ss library])],
+ AS_IF([test "x$with_ss" != "xmaybe"], AC_MSG_ERROR(ss library not found)),
+ -lcom_err -lreadline -lcurses)
+ SS_OBJS='${SS_OBJS}'
fi
+AC_SUBST(SS_LIBS)
+AC_SUBST(SS_OBJS)
LIBS="$KRB5_LIBS $KRB4_LIBS $LIBS"