summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alex Chernyakhovsky <achernya@MIT.EDU>2013-06-02 00:32:17 -0400
committerGravatar Karl Ramm <kcr@1ts.org>2013-08-08 00:00:56 -0400
commit9a79bcb678a3b26c8fa4a8231d9b7e51b0cf0b2c (patch)
tree2e92bd44abc1b0082389b2ec3d4eb7e3a3fdb91d /configure.ac
parent2d378244df7a268dc1c608c7cf8bfd6bb62e091d (diff)
Provide a pkg-config file for zephyr
Previously, it was difficult to detect the presence of the zephyr library in autoconf, and required custom macros. However, the world has since developed pkg-config, which is a simple tool for detecting the presence of a package, its compile-time flags, and its link-time flags, even in the presence of recursive dependencies. This adds "zephyr.pc" as a file generated by the build process, and installs it into the appropriate directory, allowing the target system to use PKG_CHECK_MODULES([ZEPHYR], [zephyr]) AC_SUBST([ZEPHYR_CFLAGS]) AC_SUBST([ZEPHYR_LIBS]) to detect all necessary information to incorporate the zephyr library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7278b41..647107e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -398,4 +398,5 @@ AC_OUTPUT(Makefile clients/Makefile clients/zaway/Makefile
clients/zshutdown_notify/Makefile clients/zstat/Makefile
clients/zwrite/Makefile lib/Makefile
server/Makefile zhm/Makefile zwgc/Makefile
+ zephyr.pc
)