summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-07-30 16:51:31 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-07-30 16:51:31 -0400
commitaa05cf6073cf2a6dfa46108cd5522c0171a7f1c3 (patch)
tree27405b9488362c624788da7278c57afc101a300c /Makefile.am
parentd6528405184ed3cc2a4f25b8ba86fabbc892dc59 (diff)
Make library work on both client and server sides
Replace the two-step compile/match process with a single compile-and-match one to avoid issues with server-client representation incompatibility. Use the browser regex engine on the client side.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cba5a94..0a9cf20 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,7 @@ liburweb_regex_la_SOURCES = src/regex__FFI.cc
liburweb_regex_la_DATA = \
src/lib.urp \
src/regex__FFI.h \
+ src/regex__FFI.js \
src/regex__FFI.urs \
src/regex.urs \
src/regex.ur