summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-06-23 13:52:43 -0400
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-06-23 13:52:43 -0400
commitd97efd4fb2ade6c6e9b3a3c9ba0dc870b2a025db (patch)
tree167f61b89330a3b2322f7cf0d21f6cad0e678847 /Makefile.am
parent1669102a168b6afe683d9d6fdb2417899fafc121 (diff)
configure.ac: Check for OpenSSL and Ur/Web
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d43e88..e257a97 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,14 +16,16 @@ ACLOCAL_AMFLAGS = -I m4
CPPFLAGS = \
-Wall \
- -D_FORTIFY_SOURCE=2
+ -D_FORTIFY_SOURCE=2 \
+ @OpenSSL_CFLAGS@
CXXFLAGS = \
-std=c++11 \
-ftrapv \
-fstack-protector-strong --param=ssp-buffer-size=4 \
-fPIE \
- -O2
+ -O2 \
+ @OpenSSL_CFLAGS@
CXXFLAGS += \
-Weverything \
@@ -44,7 +46,7 @@ liburweb_crypto_hash_openssl_la_DATA = \
src/hash.ur \
src/hashFFI.urs
-liburweb_crypto_hash_openssl_la_LIBADD = -lurweb
+liburweb_crypto_hash_openssl_la_LIBADD = @OpenSSL_LIBS@ -lurweb
liburweb_crypto_hash_openssl_la_LDFLAGS = -export-symbols-regex '^uw_HashFFI_'
liburweb_crypto_hash_openssl_ladir = $(datadir)/urweb/ur/crypto-hash-openssl