aboutsummaryrefslogtreecommitdiffhomepage
path: root/tensorflow/tools/pip_package/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'tensorflow/tools/pip_package/setup.py')
-rw-r--r--tensorflow/tools/pip_package/setup.py15
1 files changed, 13 insertions, 2 deletions
diff --git a/tensorflow/tools/pip_package/setup.py b/tensorflow/tools/pip_package/setup.py
index 2b840c1a3a..1c45e9e5f6 100644
--- a/tensorflow/tools/pip_package/setup.py
+++ b/tensorflow/tools/pip_package/setup.py
@@ -29,11 +29,11 @@ from setuptools.dist import Distribution
# This version string is semver compatible, but incompatible with pip.
# For pip, we will remove all '-' characters from this string, and use the
# result for pip.
-_VERSION = '1.3.0-rc2'
+_VERSION = '1.3.0'
REQUIRED_PACKAGES = [
'enum34 >= 1.1.6',
- 'numpy >= 1.11.0',
+ 'numpy >= 1.12.1',
'six >= 1.10.0',
'protobuf >= 3.3.0',
'tensorflow-tensorboard >= 0.1.0, < 0.2.0',
@@ -55,6 +55,13 @@ else:
# mock comes with unittest.mock for python3, need to install for python2
REQUIRED_PACKAGES.append('mock >= 2.0.0')
+# remove tensorboard from tf-nightly packages
+if 'tf_nightly' in project_name:
+ for package in REQUIRED_PACKAGES:
+ if 'tensorflow-tensorboard' in package:
+ REQUIRED_PACKAGES.remove(package)
+ break
+
# weakref.finalize was introduced in Python 3.4
if sys.version_info < (3, 4):
REQUIRED_PACKAGES.append('backports.weakref >= 1.0rc1')
@@ -70,6 +77,10 @@ CONSOLE_SCRIPTS = [
]
# pylint: enable=line-too-long
+# remove the tensorboard console script if building tf_nightly
+if 'tf_nightly' in project_name:
+ CONSOLE_SCRIPTS.remove('tensorboard = tensorboard.main:main')
+
TEST_PACKAGES = [
'scipy >= 0.15.1',
]