aboutsummaryrefslogtreecommitdiffhomepage
path: root/tensorflow/tools/pip_package/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'tensorflow/tools/pip_package/setup.py')
-rw-r--r--tensorflow/tools/pip_package/setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/tensorflow/tools/pip_package/setup.py b/tensorflow/tools/pip_package/setup.py
index 3dc2c5d63c..5b6ab44b59 100644
--- a/tensorflow/tools/pip_package/setup.py
+++ b/tensorflow/tools/pip_package/setup.py
@@ -29,7 +29,7 @@ from setuptools.dist import Distribution
# This version string is semver compatible, but incompatible with pip.
# For pip, we will remove all '-' characters from this string, and use the
# result for pip.
-_VERSION = '1.3.0-rc0'
+_VERSION = '1.3.0-rc1'
REQUIRED_PACKAGES = [
'numpy >= 1.11.0',
@@ -60,6 +60,11 @@ if sys.version_info < (3, 4):
# pylint: disable=line-too-long
CONSOLE_SCRIPTS = [
'saved_model_cli = tensorflow.python.tools.saved_model_cli:main',
+ # We need to keep the TensorBoard command, even though the console script
+ # is now declared by the tensorboard pip package. If we remove the
+ # TensorBoard command, pip will inappropriately remove it during install,
+ # even though the command is not removed, just moved to a different wheel.
+ 'tensorboard = tensorboard.main:main',
]
# pylint: enable=line-too-long