aboutsummaryrefslogtreecommitdiffhomepage
path: root/tensorflow/contrib/cmake/patches/jpeg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tensorflow/contrib/cmake/patches/jpeg/CMakeLists.txt')
-rw-r--r--tensorflow/contrib/cmake/patches/jpeg/CMakeLists.txt76
1 files changed, 76 insertions, 0 deletions
diff --git a/tensorflow/contrib/cmake/patches/jpeg/CMakeLists.txt b/tensorflow/contrib/cmake/patches/jpeg/CMakeLists.txt
new file mode 100644
index 0000000000..782076ef74
--- /dev/null
+++ b/tensorflow/contrib/cmake/patches/jpeg/CMakeLists.txt
@@ -0,0 +1,76 @@
+cmake_minimum_required(VERSION 2.8.3)
+
+project(libjpeg)
+
+set(LIBJPEG_SRCS
+ "jaricom.c"
+ "jcapimin.c"
+ "jcapistd.c"
+ "jcarith.c"
+ "jccoefct.c"
+ "jccolor.c"
+ "jcdctmgr.c"
+ "jchuff.c"
+ "jcinit.c"
+ "jcmainct.c"
+ "jcmarker.c"
+ "jcmaster.c"
+ "jcomapi.c"
+ "jcparam.c"
+ "jcprepct.c"
+ "jcsample.c"
+ "jctrans.c"
+ "jdapimin.c"
+ "jdapistd.c"
+ "jdarith.c"
+ "jdatadst.c"
+ "jdatasrc.c"
+ "jdcoefct.c"
+ "jdcolor.c"
+ "jddctmgr.c"
+ "jdhuff.c"
+ "jdinput.c"
+ "jdmainct.c"
+ "jdmarker.c"
+ "jdmaster.c"
+ "jdmerge.c"
+ "jdpostct.c"
+ "jdsample.c"
+ "jdtrans.c"
+ "jerror.c"
+ "jfdctflt.c"
+ "jfdctfst.c"
+ "jfdctint.c"
+ "jidctflt.c"
+ "jidctfst.c"
+ "jidctint.c"
+ "jmemmgr.c"
+ "jmemnobs.c"
+ "jquant1.c"
+ "jquant2.c"
+ "jutils.c"
+)
+set(LIBJPEG_INCLUDES
+ "jconfig.h"
+ "jdct.h"
+ "jerror.h"
+ "jinclude.h"
+ "jmemsys.h"
+ "jmorecfg.h"
+ "jpegint.h"
+ "jpeglib.h"
+ "jversion.h"
+)
+
+include_directories("${CMAKE_CURRENT_SOURCE_DIR}")
+
+add_library(libjpeg ${LIBJPEG_SRCS})
+
+install(TARGETS libjpeg
+ RUNTIME DESTINATION bin COMPONENT RuntimeLibraries
+ LIBRARY DESTINATION lib COMPONENT RuntimeLibraries
+ ARCHIVE DESTINATION lib COMPONENT Development)
+
+foreach(LIBJPEG_INCLUDE ${LIBJPEG_INCLUDES})
+ install(FILES ${LIBJPEG_INCLUDE} DESTINATION include COMPONENT Development)
+endforeach()