aboutsummaryrefslogtreecommitdiffhomepage
path: root/tensorflow/contrib/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tensorflow/contrib/cmake/CMakeLists.txt')
-rw-r--r--tensorflow/contrib/cmake/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tensorflow/contrib/cmake/CMakeLists.txt b/tensorflow/contrib/cmake/CMakeLists.txt
index 4fe5960d3b..3556e143b8 100644
--- a/tensorflow/contrib/cmake/CMakeLists.txt
+++ b/tensorflow/contrib/cmake/CMakeLists.txt
@@ -38,6 +38,8 @@ set (DOWNLOAD_LOCATION "${CMAKE_CURRENT_BINARY_DIR}/downloads"
CACHE PATH "Location where external projects will be downloaded.")
mark_as_advanced(DOWNLOAD_LOCATION)
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+
# External dependencies
include(gif)
include(png)
@@ -48,6 +50,8 @@ include(jsoncpp)
include(boringssl)
include(farmhash)
include(highwayhash)
+include(protobuf)
+include(grpc)
# Let's get to work!
include(tf_core_framework.cmake)
@@ -57,10 +61,12 @@ include(tf_core_cpu.cmake)
include(tf_models.cmake)
include(tf_core_ops.cmake)
include(tf_core_direct_session.cmake)
+include(tf_core_distributed_runtime.cmake)
include(tf_core_kernels.cmake)
include(tf_cc_ops.cmake)
include(tf_tutorials.cmake)
include(tf_tools.cmake)
+include(tf_python.cmake)
if (tensorflow_BUILD_TESTS)
include(tests.cmake)