aboutsummaryrefslogtreecommitdiffhomepage
path: root/tensorflow/contrib/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tensorflow/contrib/cmake/CMakeLists.txt')
-rw-r--r--tensorflow/contrib/cmake/CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/tensorflow/contrib/cmake/CMakeLists.txt b/tensorflow/contrib/cmake/CMakeLists.txt
index 3556e143b8..4f4497618b 100644
--- a/tensorflow/contrib/cmake/CMakeLists.txt
+++ b/tensorflow/contrib/cmake/CMakeLists.txt
@@ -16,6 +16,9 @@ cmake_policy(SET CMP0022 NEW)
# Options
option(tensorflow_VERBOSE "Enable for verbose output" OFF)
option(tensorflow_BUILD_TESTS "Build tests" ON)
+option(tensorflow_ENABLE_SSL_SUPPORT "Enable boringssl support" OFF)
+option(tensorflow_BUILD_CC_EXAMPLE "Build the C++ tutorial example" ON)
+option(tensorflow_BUILD_PYTHON_BINDINGS "Build the Python bindings" ON)
#Threads: defines CMAKE_THREAD_LIBS_INIT and adds -pthread compile option for
# targets that link ${CMAKE_THREAD_LIBS_INIT}.
@@ -44,10 +47,11 @@ set(CMAKE_POSITION_INDEPENDENT_CODE ON)
include(gif)
include(png)
include(jpeg)
-include(re2)
include(eigen)
include(jsoncpp)
-include(boringssl)
+if(tensorflow_ENABLE_SSL_SUPPORT)
+ include(boringssl)
+endif()
include(farmhash)
include(highwayhash)
include(protobuf)
@@ -64,9 +68,13 @@ include(tf_core_direct_session.cmake)
include(tf_core_distributed_runtime.cmake)
include(tf_core_kernels.cmake)
include(tf_cc_ops.cmake)
-include(tf_tutorials.cmake)
include(tf_tools.cmake)
-include(tf_python.cmake)
+if(tensorflow_BUILD_CC_EXAMPLE)
+ include(tf_tutorials.cmake)
+endif()
+if(tensorflow_BUILD_PYTHON_BINDINGS)
+ include(tf_python.cmake)
+endif()
if (tensorflow_BUILD_TESTS)
include(tests.cmake)