aboutsummaryrefslogtreecommitdiffhomepage
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 67cdb1d719..f1a96a9818 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -43,8 +43,6 @@ endfunction()
# This file is empty and is only used to trick GYP.
remove_srcs (../src/core/SkForceCPlusPlusLinking.cpp)
-# This file forces linking for all our supported image decoders. We're more fine-grained.
-remove_srcs (../src/images/SkForceLinking.cpp)
# Chrome only?
remove_srcs (../src/ports/SkFontHost_fontconfig.cpp
../src/fonts/SkFontMgr_fontconfig.cpp
@@ -166,7 +164,7 @@ endif()
if (GIF_FOUND)
list (APPEND private_includes ${GIF_INCLUDE_DIRS})
list (APPEND libs ${GIF_LIBRARIES})
- add_definitions(-DSK_CODEC_DECODES_GIF)
+ add_definitions(-DSK_HAS_GIF_LIBRARY)
else()
remove_srcs(../src/images/*GIF*)
remove_srcs(../src/codec/*Gif*)
@@ -175,7 +173,7 @@ endif()
if (JPEG_FOUND)
list (APPEND private_includes ${JPEG_INCLUDE_DIRS})
list (APPEND libs ${JPEG_LIBRARIES})
- add_definitions(-DSK_CODEC_DECODES_JPEG)
+ add_definitions(-DSK_HAS_JPEG_LIBRARY)
else()
remove_srcs(../src/images/*JPEG*)
remove_srcs(../src/codec/*Jpeg*)
@@ -193,7 +191,7 @@ if (PNG_FOUND)
list (APPEND libs ${PNG_LIBRARIES})
add_definitions(-DPNG_SKIP_SETJMP_CHECK)
add_definitions(-DPNG_SKIP_SKIA_OPTS)
- add_definitions(-DSK_CODEC_DECODES_PNG)
+ add_definitions(-DSK_HAS_PNG_LIBRARY)
else()
remove_srcs(../src/images/*PNG*)
remove_srcs(../src/codec/*Png*)
@@ -212,7 +210,7 @@ endif()
if (WEBP_INCLUDE_DIRS AND WEBP_LIBRARIES)
list (APPEND private_includes ${WEBP_INCLUDE_DIRS})
list (APPEND libs ${WEBP_LIBRARIES})
- add_definitions(-DSK_CODEC_DECODES_WEBP)
+ add_definitions(-DSK_HAS_WEBP_LIBRARY)
else()
remove_srcs(../src/images/*WEBP*)
remove_srcs(../src/codec/*Webp*)