aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..751bd39
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,46 @@
+# Copyright 2016 Benjamin Barenblat
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may not
+# use this file except in compliance with the License. You may obtain a copy of
+# the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations under
+# the License.
+
+include(FindPkgConfig)
+
+pkg_check_modules(FUSE REQUIRED fuse)
+pkg_check_modules(GLOG REQUIRED libglog)
+
+link_directories(
+ ${FUSE_LIBRARY_DIRS}
+ ${GLOG_LIBRARY_DIRS}
+)
+set(
+ CMAKE_CXX_FLAGS
+ "${CMAKE_CXX_FLAGS} ${FUSE_CFLAGS_OTHER} ${GLOG_CFLAGS_OTHER}"
+)
+set(
+ CMAKE_EXE_LINKER_FLAGS
+ "${CMAKE_EXE_LINKER_FLAGS} ${FUSE_LDFLAGS_OTHER} ${GLOG_LDFLAGS_OTHER}"
+)
+
+add_executable(
+ scoville
+ scoville.cc
+)
+target_include_directories(
+ scoville
+ PRIVATE ${FUSE_INCLUDE_DIRS}
+ PRIVATE ${GLOG_INCLUDE_DIRS}
+)
+target_link_libraries(
+ scoville
+ ${FUSE_LIBRARIES}
+ ${GLOG_LIBRARIES}
+)