aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2016-02-13 15:24:52 -0500
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2016-02-13 15:24:52 -0500
commit34eb0db1e04cbfc0504c239a151247334f1bb0a8 (patch)
treeca141ef419acd031ec713659caf735266543f84d /src/CMakeLists.txt
parentd9370d044e237df9df9336adad836956d42d7c85 (diff)
Make FUSE and glog be system includes
Prevent obnoxious error messages by making FUSE and glog be included with -isystem instead of -I.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 5f1b286..f2f0c0f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -38,8 +38,8 @@ add_executable(
)
target_include_directories(
scoville
- PRIVATE ${FUSE_INCLUDE_DIRS}
- PRIVATE ${GLOG_INCLUDE_DIRS}
+ SYSTEM PRIVATE ${FUSE_INCLUDE_DIRS}
+ SYSTEM PRIVATE ${GLOG_INCLUDE_DIRS}
)
target_link_libraries(
scoville