aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2016-02-13 15:24:52 -0500
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2016-02-13 15:24:52 -0500
commit34eb0db1e04cbfc0504c239a151247334f1bb0a8 (patch)
treeca141ef419acd031ec713659caf735266543f84d /CMakeLists.txt
parentd9370d044e237df9df9336adad836956d42d7c85 (diff)
Make FUSE and glog be system includes
Prevent obnoxious error messages by making FUSE and glog be included with -isystem instead of -I.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a664713..8121a56 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,5 +29,6 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -ftrapv")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fstack-protector-strong --param=ssp-buffer-size=4")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Weverything -Wno-c++98-compat")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-weak-vtables")
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-unused-macros")
add_subdirectory(src)