aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Paul Yang <TeBoring@users.noreply.github.com>2018-06-28 13:48:06 -0700
committerGravatar GitHub <noreply@github.com>2018-06-28 13:48:06 -0700
commitf25e7edfa40c12300cf7dd3837b82841d095a79a (patch)
tree40ed1cec0eb61aa8f2c1b98a4b324453de9f6ed5 /src/Makefile.am
parent70544627cb89a61652d688c53984c68013ab985e (diff)
Add -Og to no-warning-test (#4830)
* Add -Og to no-warning-test * Initialize value * Implement PrintFieldName in CompactRepeatedFieldPrinter to prevent Woverloaded-virtual * Update generated code
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 09ab76f7..cb1b1006 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -876,7 +876,7 @@ no_warning_test.cc:
no_warning_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la
no_warning_test_CXXFLAGS = $(PTHREAD_CFLAGS) $(PTHREAD_DEF) $(ZLIB_DEF) \
- -Wall -Wextra -Werror -Wno-unused-parameter
+ -Wall -Wextra -Werror -Wno-unused-parameter -Og
nodist_no_warning_test_SOURCES = no_warning_test.cc $(protoc_outputs)
TESTS = protobuf-test protobuf-lazy-descriptor-test protobuf-lite-test \