aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Adam Cozzette <acozzette@google.com>2016-12-20 10:25:11 -0800
committerGravatar Adam Cozzette <acozzette@google.com>2016-12-20 15:47:51 -0800
commitee0a24346e6542d81b47b3be60c215ffb9b06d1e (patch)
tree764c62c27b4fb1708ce79109107e55e67b2ee2ce /src/Makefile.am
parentd1e7bd98428a321eab793f3dd099392dd364d9cd (diff)
Updated Makefile.am to fix out-of-tree builds
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 254d428f..2f54be0f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -494,8 +494,10 @@ js_well_known_types_sources = \
google/protobuf/compiler/js/well_known_types/any.js \
google/protobuf/compiler/js/well_known_types/struct.js \
google/protobuf/compiler/js/well_known_types/timestamp.js
+# We have to cd to $(srcdir) so that out-of-tree builds work properly.
google/protobuf/compiler/js/well_known_types_embed.cc: js_embed$(EXEEXT) $(js_well_known_types_sources)
- ./js_embed$(EXEEXT) $(js_well_known_types_sources) > $@
+ oldpwd=`pwd` && cd $(srcdir) && \
+ $$oldpwd/js_embed$(EXEEXT) $(js_well_known_types_sources) > $$oldpwd/$@
# Tests ==============================================================
@@ -549,6 +551,7 @@ protoc_inputs = \
EXTRA_DIST = \
$(protoc_inputs) \
+ $(js_well_known_types_sources) \
solaris/libstdc++.la \
google/protobuf/io/gzip_stream.h \
google/protobuf/io/gzip_stream_unittest.sh \