aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Jisi Liu <jisi.liu@gmail.com>2017-08-10 10:47:06 -0700
committerGravatar Jisi Liu <jisi.liu@gmail.com>2017-08-10 10:47:06 -0700
commite8fc0661db2d6eaf2e2aff13efe8cda659e35024 (patch)
tree075274842c436ed025f7ff98f8a200732d6b9a0e /src/Makefile.am
parent97d50e306e576dadf2184e643b7c934da45730c8 (diff)
Make no warning test stricter.
- Now it includes -Wextra except for unused-parameter. - Removed gtest dependency
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 7 insertions, 12 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7515b542..1999213c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -681,10 +681,10 @@ protoc_outputs = \
google/protobuf/unittest_preserve_unknown_enum.pb.h \
google/protobuf/unittest_proto3_arena.pb.cc \
google/protobuf/unittest_proto3_arena.pb.h \
- google/protobuf/unittest_proto3_arena_lite.pb.cc \
- google/protobuf/unittest_proto3_arena_lite.pb.h \
- google/protobuf/unittest_proto3_lite.pb.cc \
- google/protobuf/unittest_proto3_lite.pb.h \
+ google/protobuf/unittest_proto3_arena_lite.pb.cc \
+ google/protobuf/unittest_proto3_arena_lite.pb.h \
+ google/protobuf/unittest_proto3_lite.pb.cc \
+ google/protobuf/unittest_proto3_lite.pb.h \
google/protobuf/unittest_well_known_types.pb.cc \
google/protobuf/unittest_well_known_types.pb.h \
google/protobuf/util/internal/testdata/anys.pb.cc \
@@ -922,16 +922,11 @@ no_warning_test.cc:
echo "#include <$${FILE}>" >> no_warning_test.cc; \
fi \
done
- echo "#include <gtest/gtest.h>" >> no_warning_test.cc
- echo "TEST(NoWarningTest, Empty) {}" >> no_warning_test.cc
+ echo "int main(int, char**) { return 0; }" >> no_warning_test.cc
-no_warning_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la \
- ../gmock/gtest/lib/libgtest.la \
- ../gmock/gtest/lib/libgtest_main.la
-no_warning_test_CPPFLAGS = -I$(srcdir)/../gmock/gtest/include
+no_warning_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la
no_warning_test_CXXFLAGS = $(PTHREAD_CFLAGS) $(PTHREAD_DEF) $(ZLIB_DEF) \
- -Wall -Werror -Werror=missing-declarations \
- -Werror=missing-field-initializers
+ -Wall -Wextra -Werror -Wno-unused-parameter
nodist_no_warning_test_SOURCES = no_warning_test.cc $(protoc_outputs)
TESTS = protobuf-test protobuf-lazy-descriptor-test protobuf-lite-test \