aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Jisi Liu <liujisi@google.com>2015-06-13 08:44:19 -0700
committerGravatar Jisi Liu <liujisi@google.com>2015-06-13 08:44:19 -0700
commitcf141287ea7f99dd77c00485df426737068e8297 (patch)
tree4992b7ef0c867a86bfb65e7d1e1fd3396320f6df /src/Makefile.am
parent52737c2bc8150b5b31ee5523eacd52e802706efc (diff)
parentf48dca504443c17c2bf86104754c405b503073cc (diff)
Merge pull request #495 from pherl/master
Make pbconfig.h independent of config.h
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 3 insertions, 18 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7d3a5945..ac6ec6f4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -41,24 +41,12 @@ nobase_dist_proto_DATA = google/protobuf/descriptor.proto \
clean-local:
rm -f *.loT
-public_config = google/protobuf/stubs/pbconfig.h
-
-CLEANFILES = $(protoc_outputs) $(public_config) unittest_proto_middleman \
+CLEANFILES = $(protoc_outputs) unittest_proto_middleman \
testzip.jar testzip.list testzip.proto testzip.zip
MAINTAINERCLEANFILES = \
Makefile.in
-# Generate and distribute a minimum config.h file to make hash_map work.
-# The autoheader config has too much info, which might conflict with other
-# macros applications might include. Thus, we create a stubs/pbconfig.h, that
-# only #defines what we really need, and prefix it with GOOGLE_PROTOBUF_ to
-# avoid conflicts.
-$(public_config): $(top_builddir)/config.h $(top_srcdir)/config.h.include
- echo "// Note: Google Protobuf internal only. Do NOT include." > $@
- cat $(top_builddir)/config.h | grep -f $(top_srcdir)/config.h.include | \
- sed 's,#define , #define GOOGLE_PROTOBUF_,' >> $@
-
nobase_include_HEADERS = \
google/protobuf/stubs/atomic_sequence_num.h \
google/protobuf/stubs/atomicops.h \
@@ -80,6 +68,7 @@ nobase_include_HEADERS = \
google/protobuf/stubs/fastmem.h \
google/protobuf/stubs/hash.h \
google/protobuf/stubs/once.h \
+ google/protobuf/stubs/pbconfig.h \
google/protobuf/stubs/platform_macros.h \
google/protobuf/stubs/shared_ptr.h \
google/protobuf/stubs/singleton.h \
@@ -152,9 +141,6 @@ nobase_include_HEADERS = \
google/protobuf/compiler/ruby/ruby_generator.h \
google/protobuf/compiler/csharp/csharp_generator.h
-nobase_nodist_include_HEADERS = \
- $(public_config)
-
lib_LTLIBRARIES = libprotobuf-lite.la libprotobuf.la libprotoc.la
libprotobuf_lite_la_LIBADD = $(PTHREAD_LIBS)
@@ -180,7 +166,6 @@ libprotobuf_lite_la_SOURCES = \
google/protobuf/io/coded_stream_inl.h \
google/protobuf/io/zero_copy_stream.cc \
google/protobuf/io/zero_copy_stream_impl_lite.cc
-nodist_libprotobuf_lite_la_SOURCES = $(public_config)
libprotobuf_la_LIBADD = $(PTHREAD_LIBS)
libprotobuf_la_LDFLAGS = -version-info 10:0:0 -export-dynamic -no-undefined
@@ -519,7 +504,7 @@ protoc_outputs = \
google/protobuf/compiler/cpp/cpp_test_bad_identifiers.pb.cc \
google/protobuf/compiler/cpp/cpp_test_bad_identifiers.pb.h
-BUILT_SOURCES = $(public_config) $(protoc_outputs)
+BUILT_SOURCES = $(protoc_outputs)
if USE_EXTERNAL_PROTOC