aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Gaurav Vaish <gaurav.vaish@gmail.com>2016-03-24 11:44:56 -0700
committerGravatar Gaurav Vaish <gaurav.vaish@gmail.com>2016-04-05 09:47:11 -0700
commit74d8b0bebc233331b1861354908f7fa0fde9d769 (patch)
treee99c0b9bb481959a32e32f5b2c539d7edaa74aae /src/Makefile.am
parent452e2b2c5c607ab5d63cd813793f1aa960f19d1c (diff)
Added access_level for types
* `csharp_options`: Added `Options` to encapsulate generator options. Supported options for now - file_extension, base_namespace * `{Blah}Generator`: Now accept `Options*` as parameter to constructor * `csharp_generator.cc`: Parse and populate options * `Makefile.am`: Added `csharp_options.h` * `extract_includes.bat.in`: Added `csharp_options.h` Refactoring code to two commits. This is the first commit
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 073673a5..2ba0ef9b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -455,6 +455,7 @@ libprotoc_la_SOURCES = \
google/protobuf/compiler/csharp/csharp_message.h \
google/protobuf/compiler/csharp/csharp_message_field.cc \
google/protobuf/compiler/csharp/csharp_message_field.h \
+ google/protobuf/compiler/csharp/csharp_options.h \
google/protobuf/compiler/csharp/csharp_primitive_field.cc \
google/protobuf/compiler/csharp/csharp_primitive_field.h \
google/protobuf/compiler/csharp/csharp_reflection_class.cc \