aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Jisi Liu <jisi.liu@gmail.com>2017-11-08 15:27:48 -0800
committerGravatar Jisi Liu <jisi.liu@gmail.com>2017-11-08 15:27:48 -0800
commit181e284b55dd234320b0e4fd5fbc81a5dfa6b580 (patch)
tree9a0bcb181af9ff91eea5be98abd13dd42a5c9e37 /src/Makefile.am
parent1144768dd63effc560a3d64996398d149620b575 (diff)
Fix Atomic32/AtomicWord on some platforms.
- Removed the redefination in the atomicword_compat.h. Now Atomic32 will alwyas be intptr_t in 32bit platforms, the bridge is no longer needed. - Change NaCl 64bit to use intptr_t instead of int32 for Atomic32, otherwise AtmoicWord APIs will miss the definations. After this change, the AtmoicWord will always be either Atomic32 or Atmoic64 depending on the platforms.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bff3ae5a..1d651dc8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -71,7 +71,6 @@ nobase_include_HEADERS = \
google/protobuf/stubs/atomicops_internals_arm64_gcc.h \
google/protobuf/stubs/atomicops_internals_arm_gcc.h \
google/protobuf/stubs/atomicops_internals_arm_qnx.h \
- google/protobuf/stubs/atomicops_internals_atomicword_compat.h \
google/protobuf/stubs/atomicops_internals_generic_c11_atomic.h \
google/protobuf/stubs/atomicops_internals_generic_gcc.h \
google/protobuf/stubs/atomicops_internals_mips_gcc.h \