aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Adam Cozzette <acozzette@google.com>2017-01-06 12:01:26 -0800
committerGravatar Adam Cozzette <acozzette@google.com>2017-01-09 09:38:14 -0800
commit0bdf4a617f100e613a774117c98bc8e670c407cc (patch)
tree2b7369ccc327bb3cc54ae4a968a49e767e8032da /src/Makefile.am
parent2bddffc993db05df57b6ebaea18f42c7b31753e9 (diff)
Fixed "make distcheck" for the Autotools build
To make the test pass I needed to fix out-of-tree builds and update EXTRA_DIST and CLEANFILES.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5130d0b1..8807effd 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -57,7 +57,8 @@ clean-local:
CLEANFILES = $(protoc_outputs) unittest_proto_middleman \
testzip.jar testzip.list testzip.proto testzip.zip \
no_warning_test.cc \
- google/protobuf/compiler/js/well_known_types_embed.cc
+ google/protobuf/compiler/js/well_known_types_embed.cc \
+ js_embed$(EXEEXT)
MAINTAINERCLEANFILES = \
Makefile.in
@@ -492,7 +493,7 @@ protoc_SOURCES = google/protobuf/compiler/main.cc
# well_known_types_embed.cc, which is generated from .js source files. We have
# to build the js_embed binary using $(CXX_FOR_BUILD) so that it is executable
# on the build machine in a cross-compilation setup.
-js_embed$(EXEEXT): google/protobuf/compiler/js/embed.cc
+js_embed$(EXEEXT): $(srcdir)/google/protobuf/compiler/js/embed.cc
$(CXX_FOR_BUILD) -o $@ $<
js_well_known_types_sources = \
google/protobuf/compiler/js/well_known_types/any.js \
@@ -575,6 +576,7 @@ EXTRA_DIST = \
google/protobuf/package_info.h \
google/protobuf/io/package_info.h \
google/protobuf/util/package_info.h \
+ google/protobuf/compiler/js/embed.cc \
google/protobuf/compiler/ruby/ruby_generated_code.proto \
google/protobuf/compiler/ruby/ruby_generated_code_pb.rb \
google/protobuf/compiler/package_info.h \