aboutsummaryrefslogtreecommitdiffhomepage
path: root/python/setup.py
diff options
context:
space:
mode:
authorGravatar Feng Xiao <xfxyjwf@gmail.com>2014-11-25 15:21:08 -0800
committerGravatar Feng Xiao <xfxyjwf@gmail.com>2014-11-25 15:21:08 -0800
commitd1ec493a12531ca8e9a8a2d3444e77348dca8145 (patch)
treec0e4765821969fe85da8158b82d5992a8ecab817 /python/setup.py
parent7d2db50b219b1f1358c12daa0309e657f654469e (diff)
Fix Python C++ implementation build issues:
1. Haven't included the include path for "config.h". 2. Use of C++11 auto keyword.
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/setup.py b/python/setup.py
index 7337260a..69ffcd1d 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -157,7 +157,7 @@ if __name__ == '__main__':
"google/protobuf/pyext/repeated_scalar_container.cc",
"google/protobuf/pyext/repeated_composite_container.cc" ],
define_macros=[('GOOGLE_PROTOBUF_HAS_ONEOF', '1')],
- include_dirs = [ ".", "../src"],
+ include_dirs = [ ".", "..", "../src"],
libraries = [ "protobuf" ],
library_dirs = [ '../src/.libs' ],
))