aboutsummaryrefslogtreecommitdiffhomepage
path: root/python/setup.py
diff options
context:
space:
mode:
authorGravatar Feng Xiao <xfxyjwf@gmail.com>2015-12-22 14:36:04 -0800
committerGravatar Feng Xiao <xfxyjwf@gmail.com>2015-12-28 14:18:49 -0800
commitb7610f129df84d7f823f64d5dce9bfa1578cf49e (patch)
tree0da8267d920a3c6c5b20ae983d09c8d8967ee0cd /python/setup.py
parent7f82325998a1812c119eb8894bc3bee21dd99628 (diff)
Add missing files to EXTRA_DIST.
Also delete some unused files.
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/python/setup.py b/python/setup.py
index 22f6e816..1e71a702 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -114,7 +114,8 @@ class clean(_clean):
filepath = os.path.join(dirpath, filename)
if filepath.endswith("_pb2.py") or filepath.endswith(".pyc") or \
filepath.endswith(".so") or filepath.endswith(".o") or \
- filepath.endswith('google/protobuf/compiler/__init__.py'):
+ filepath.endswith('google/protobuf/compiler/__init__.py') or \
+ filepath.endswith('google/protobuf/util/__init__.py'):
os.remove(filepath)
# _clean is an old-style class, so super() doesn't work.
_clean.run(self)
@@ -137,7 +138,7 @@ class build_py(_build_py):
GenerateUnittestProtos()
# Make sure google.protobuf/** are valid packages.
- for path in ['', 'internal/', 'compiler/', 'pyext/']:
+ for path in ['', 'internal/', 'compiler/', 'pyext/', 'util/']:
try:
open('google/protobuf/%s__init__.py' % path, 'a').close()
except EnvironmentError: