aboutsummaryrefslogtreecommitdiffhomepage
path: root/python/setup.py
diff options
context:
space:
mode:
authorGravatar Dwayne Litzenberger <dlitz@dlitz.net>2014-10-14 13:50:00 -0700
committerGravatar Dwayne Litzenberger <dlitz@dlitz.net>2014-10-14 13:50:52 -0700
commitb460610b69b8ab9096e3da9423379200fefad3a5 (patch)
treebead294b6351bafdff6a33304b5e6693a6f97ab3 /python/setup.py
parent0fd260eae7a53483a4be5b265effba3daacd84c7 (diff)
Omit google-apputils dependency under Python 3
Temporary change until a py3k-compatible google-apputils is released.
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/setup.py b/python/setup.py
index 99c1ca9f..7a8f5f1e 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -194,7 +194,11 @@ if __name__ == '__main__':
'google.protobuf.text_format'],
cmdclass = { 'clean': clean, 'build_py': build_py },
install_requires = ['setuptools'],
- setup_requires = ['google-apputils'],
+ # TODO: Restore dependency once a Python 3 compatible google-apputils
+ # is released.
+ setup_requires = (['google-apputils']
+ if sys.version_info[0] < 3 else
+ []),
ext_modules = ext_module_list,
url = 'https://developers.google.com/protocol-buffers/',
maintainer = maintainer_email,