aboutsummaryrefslogtreecommitdiffhomepage
path: root/python/setup.py
diff options
context:
space:
mode:
authorGravatar Tamir Duberstein <tamird@gmail.com>2015-01-13 14:47:32 -0500
committerGravatar Tamir Duberstein <tamird@gmail.com>2015-04-10 19:43:51 -0400
commit9f42f5f4a423b923f7b07ae8c5e8db4943df49c6 (patch)
treefd376cb74cae08e5bc77a8f23a797d8d5f49cc44 /python/setup.py
parentdab96f19ee2cb1dab5a403987329326ee23c2191 (diff)
[PYTHON] Drop dependency on 'google.apputils'.
Use stdlib's 'unittest' instead.
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py7
1 files changed, 1 insertions, 6 deletions
diff --git a/python/setup.py b/python/setup.py
index 2226fb11..fa98cd31 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -165,7 +165,7 @@ if __name__ == '__main__':
version = GetVersion(),
packages = [ 'google' ],
namespace_packages = [ 'google' ],
- google_test_dir = "google/protobuf/internal",
+ test_suite = 'google.protobuf.internal',
# Must list modules explicitly so that we don't install tests.
py_modules = [
'google.protobuf.internal.api_implementation',
@@ -194,11 +194,6 @@ if __name__ == '__main__':
'google.protobuf.text_format'],
cmdclass = { 'clean': clean, 'build_py': build_py },
install_requires = ['setuptools'],
- # TODO: Restore dependency once a Python 3 compatible google-apputils
- # is released.
- setup_requires = (['google-apputils']
- if sys.version_info[0] < 3 else
- []),
ext_modules = ext_module_list,
url = 'https://developers.google.com/protocol-buffers/',
maintainer = maintainer_email,