aboutsummaryrefslogtreecommitdiffhomepage
path: root/python/setup.py
diff options
context:
space:
mode:
authorGravatar Yuchen Xie <yuchen.xie@live.com>2018-06-26 06:20:53 +0800
committerGravatar Jie Luo <anandolee@gmail.com>2018-06-25 15:20:53 -0700
commit595231dd5cc92c3ac64faa39f22707b5ec58731a (patch)
tree815fdbda53551ae7373845f053848451ea8310be /python/setup.py
parentd65d5821bc76a5e43bfac0a227d970f5bc88b789 (diff)
Update minimal Python version to 2.7 (#4207)
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/python/setup.py b/python/setup.py
index 1a282f99..ebbe1bb6 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -149,10 +149,9 @@ class build_py(_build_py):
class test_conformance(_build_py):
target = 'test_python'
def run(self):
- if sys.version_info >= (2, 7):
- # Python 2.6 dodges these extra failures.
- os.environ["CONFORMANCE_PYTHON_EXTRA_FAILURES"] = (
- "--failure_list failure_list_python-post26.txt")
+ # Python 2.6 dodges these extra failures.
+ os.environ["CONFORMANCE_PYTHON_EXTRA_FAILURES"] = (
+ "--failure_list failure_list_python-post26.txt")
cmd = 'cd ../conformance && make %s' % (test_conformance.target)
status = subprocess.check_call(cmd, shell=True)