aboutsummaryrefslogtreecommitdiffhomepage
path: root/python/setup.py
diff options
context:
space:
mode:
authorGravatar Behzad Tabibian <btabibian@gmail.com>2015-04-28 11:09:05 +0200
committerGravatar Behzad Tabibian <btabibian@gmail.com>2015-04-28 11:09:05 +0200
commit4b4770280dc2aead50708b783825cf4d24b6d407 (patch)
tree54b75945d219ba09c423147ed942816aad8d259b /python/setup.py
parent0a1763b6afe166c546f9e91c2147d981d03a42e8 (diff)
adding globals() to exec call for python3 compatibility
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/setup.py b/python/setup.py
index c18818e2..07cc56e7 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -52,7 +52,7 @@ def GetVersion():
"""
with open(os.path.join('google', 'protobuf', '__init__.py')) as version_file:
- exec(version_file.read())
+ exec(version_file.read(),globals())
return __version__