aboutsummaryrefslogtreecommitdiffhomepage
path: root/python/setup.py
diff options
context:
space:
mode:
authorGravatar Jisi Liu <jisi.liu@gmail.com>2015-03-04 16:45:13 -0800
committerGravatar Jisi Liu <jisi.liu@gmail.com>2015-03-04 16:45:13 -0800
commit4573e110b89d3b1288f2f9f611fc85b91256db3a (patch)
tree8391742471324566d3e454b6911c819bf18a1cc6 /python/setup.py
parente4a9ace5415477feaefd70a2af2d0e93e83213a3 (diff)
Fix python versions to comply with pep-0440.
Change-Id: Ifb4958e4f371b36f249faa466473f851697edb5c
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py14
1 files changed, 13 insertions, 1 deletions
diff --git a/python/setup.py b/python/setup.py
index b97fdaea..c18818e2 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -44,6 +44,18 @@ elif os.path.exists("../vsprojects/Release/protoc.exe"):
else:
protoc = find_executable("protoc")
+def GetVersion():
+ """Gets the version from google/protobuf/__init__.py
+
+ Do not import google.protobuf.__init__ directly, because an installed protobuf
+ library may be loaded instead.
+
+ """
+ with open(os.path.join('google', 'protobuf', '__init__.py')) as version_file:
+ exec(version_file.read())
+ return __version__
+
+
def generate_proto(source):
"""Invokes the Protocol Compiler to generate a _pb2.py from the given
.proto file. Does nothing if the output already exists and is newer than
@@ -150,7 +162,7 @@ if __name__ == '__main__':
os.environ['PROTOCOL_BUFFERS_PYTHON_IMPLEMENTATION'] = 'cpp'
setup(name = 'protobuf',
- version = '3.0.0-alpha-3-pre',
+ version = GetVersion(),
packages = [ 'google' ],
namespace_packages = [ 'google' ],
google_test_dir = "google/protobuf/internal",