aboutsummaryrefslogtreecommitdiffhomepage
path: root/python/setup.py
diff options
context:
space:
mode:
authorGravatar Dan O'Reilly <oreilldf@gmail.com>2015-08-20 13:51:26 -0400
committerGravatar Dan O'Reilly <oreilldf@gmail.com>2015-08-20 13:52:19 -0400
commit3bdfb4b6951ad3db1a9493e86cd76f4f1c4d8986 (patch)
treea81cd74e62868303d027c27059ca5476bf510f9d /python/setup.py
parent9d689692d334b34a4e085fd9982c11761fd1c128 (diff)
Add some clarifying comments. Remove ez_setup.py.
Signed-off-by: Dan O'Reilly <oreilldf@gmail.com>
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py14
1 files changed, 1 insertions, 13 deletions
diff --git a/python/setup.py b/python/setup.py
index 79e23698..23193cba 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -8,19 +8,7 @@ import sys
# We must use setuptools, not distutils, because we need to use the
# namespace_packages option for the "google" package.
-try:
- from setuptools import setup, Extension, find_packages
-except ImportError:
- try:
- from ez_setup import use_setuptools
- use_setuptools()
- from setuptools import setup, Extension, find_packages
- except ImportError:
- sys.stderr.write(
- "Could not import setuptools; make sure you have setuptools or "
- "ez_setup installed.\n"
- )
- raise
+from setuptools import setup, Extension, find_packages
from distutils.command.clean import clean as _clean