aboutsummaryrefslogtreecommitdiffhomepage
path: root/python/setup.py
diff options
context:
space:
mode:
authorGravatar Tres Seaver <tseaver@palladion.com>2015-01-13 15:59:09 -0500
committerGravatar Tres Seaver <tseaver@palladion.com>2015-01-13 15:59:09 -0500
commit11de4197737d310ab59048c2f7162e4dce96c1a4 (patch)
tree9c3d7e6e4ea6efb4ece872115b5f3052e3c98c36 /python/setup.py
parentc0f673d0dcb07fd580144a2c74cb50086f4b746d (diff)
parente17f78bbbf16bc318a9aa8776a100271936efb43 (diff)
Merge branch 'python-update_setup' into straddle_py2_py3
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py55
1 files changed, 18 insertions, 37 deletions
diff --git a/python/setup.py b/python/setup.py
index a4015d8a..3739dc45 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -8,12 +8,12 @@ import subprocess
# We must use setuptools, not distutils, because we need to use the
# namespace_packages option for the "google" package.
try:
- from setuptools import setup, Extension
+ from setuptools import setup, Extension, find_packages
except ImportError:
try:
from ez_setup import use_setuptools
use_setuptools()
- from setuptools import setup, Extension
+ from setuptools import setup, Extension, find_packages
except ImportError:
sys.stderr.write(
"Could not import setuptools; make sure you have setuptools or "
@@ -157,45 +157,26 @@ if __name__ == '__main__':
setup(name = 'protobuf',
version = '3.0.0-pre',
- packages = [ 'google' ],
+ description = 'Protocol Buffers',
+ long_description =
+ "Protocol Buffers are Google's data interchange format.",
+ url = 'https://developers.google.com/protocol-buffers/',
+ maintainer = maintainer_email,
+ maintainer_email = 'protobuf@googlegroups.com',
+ license = 'New BSD License',
+ classifiers=[
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ ],
namespace_packages = [ 'google' ],
+ packages = find_packages(
+ exclude=[
+ "import_test_package",
+ ]),
test_suite = 'setup.MakeTestSuite',
google_test_dir = "google/protobuf/internal",
- # Must list modules explicitly so that we don't install tests.
- py_modules = [
- 'google.protobuf.internal.api_implementation',
- 'google.protobuf.internal.containers',
- 'google.protobuf.internal.cpp_message',
- 'google.protobuf.internal.decoder',
- 'google.protobuf.internal.encoder',
- 'google.protobuf.internal.enum_type_wrapper',
- 'google.protobuf.internal.message_listener',
- 'google.protobuf.internal.python_message',
- 'google.protobuf.internal.type_checkers',
- 'google.protobuf.internal.wire_format',
- 'google.protobuf.descriptor',
- 'google.protobuf.descriptor_pb2',
- 'google.protobuf.compiler.plugin_pb2',
- 'google.protobuf.message',
- 'google.protobuf.descriptor_database',
- 'google.protobuf.descriptor_pool',
- 'google.protobuf.message_factory',
- 'google.protobuf.proto_builder',
- 'google.protobuf.pyext.cpp_message',
- 'google.protobuf.reflection',
- 'google.protobuf.service',
- 'google.protobuf.service_reflection',
- 'google.protobuf.symbol_database',
- 'google.protobuf.text_encoding',
- 'google.protobuf.text_format'],
cmdclass = { 'clean': clean, 'build_py': build_py },
install_requires = ['setuptools', 'six'],
ext_modules = ext_module_list,
- url = 'https://developers.google.com/protocol-buffers/',
- maintainer = maintainer_email,
- maintainer_email = 'protobuf@googlegroups.com',
- license = 'New BSD License',
- description = 'Protocol Buffers',
- long_description =
- "Protocol Buffers are Google's data interchange format.",
)