aboutsummaryrefslogtreecommitdiffhomepage
path: root/conformance/Makefile.am
diff options
context:
space:
mode:
authorGravatar Josh Haberman <jhaberman@gmail.com>2015-12-30 16:03:49 -0800
committerGravatar Josh Haberman <jhaberman@gmail.com>2016-01-11 16:15:46 -0800
commite891c29f9bc6aec94db80d44ed8c24d4142f7c3f (patch)
treecf2b27b5a8fda53820c724d5ab130247c4ff4ddc /conformance/Makefile.am
parentc64146f195881f349bf470948d7b5e1e3704b077 (diff)
Allow conformance test runner to tolerate crashes, and re-enable conformance tests.
Diffstat (limited to 'conformance/Makefile.am')
-rw-r--r--conformance/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/conformance/Makefile.am b/conformance/Makefile.am
index 89d87d3e..79134634 100644
--- a/conformance/Makefile.am
+++ b/conformance/Makefile.am
@@ -1,7 +1,14 @@
## Process this file with automake to produce Makefile.in
protoc_inputs = \
- conformance.proto
+ conformance.proto \
+ $(top_srcdir)/src/google/protobuf/any.proto \
+ $(top_srcdir)/src/google/protobuf/duration.proto \
+ $(top_srcdir)/src/google/protobuf/field_mask.proto \
+ $(top_srcdir)/src/google/protobuf/struct.proto \
+ $(top_srcdir)/src/google/protobuf/timestamp.proto \
+ $(top_srcdir)/src/google/protobuf/wrappers.proto
+
protoc_outputs = \
conformance.pb.cc \
@@ -75,7 +82,7 @@ endif
if USE_EXTERNAL_PROTOC
protoc_middleman: $(protoc_inputs)
- $(PROTOC) -I$(srcdir) --cpp_out=. --java_out=. --ruby_out=. --objc_out=. --python_out=.$^
+ $(PROTOC) -I$(srcdir) -I$(top_srcdir) --cpp_out=. --java_out=. --ruby_out=. --objc_out=. --python_out=.$^
touch protoc_middleman
else
@@ -135,10 +142,10 @@ test_ruby: protoc_middleman conformance-test-runner $(other_language_protoc_outp
# These depend on library paths being properly set up. The easiest way to
# run them is to just use "tox" from the python dir.
test_python: protoc_middleman conformance-test-runner
- ./conformance-test-runner --failure_list failure_list_python.txt ./conformance_python.py
+ ./conformance-test-runner --failure_list failure_list_python.txt $(CONFORMANCE_PYTHON_EXTRA_FAILURES) ./conformance_python.py
test_python_cpp: protoc_middleman conformance-test-runner
- ./conformance-test-runner --failure_list failure_list_python_cpp.txt ./conformance_python.py
+ ./conformance-test-runner --failure_list failure_list_python_cpp.txt $(CONFORMANCE_PYTHON_EXTRA_FAILURES) ./conformance_python.py
if OBJC_CONFORMANCE_TEST