aboutsummaryrefslogtreecommitdiffhomepage
path: root/conformance/Makefile.am
diff options
context:
space:
mode:
authorGravatar Josh Haberman <jhaberman@gmail.com>2016-05-17 18:07:39 -0700
committerGravatar Josh Haberman <jhaberman@gmail.com>2016-06-03 09:39:38 -0700
commitbd98eae1c944e453784cdf96c05cc40de55a9690 (patch)
tree7698c6534763424ffbcb86f84bfeebdadc8d2d0d /conformance/Makefile.am
parentef7894e2dc6d287419e42a4fdc52cdfedd386d16 (diff)
Fixed Python by updating failure lists and fixed a few broken tests.
Python 2.x doesn't detect unpaired surrogates so we have to do that manually.
Diffstat (limited to 'conformance/Makefile.am')
-rw-r--r--conformance/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/conformance/Makefile.am b/conformance/Makefile.am
index 31a9e408..5538cc75 100644
--- a/conformance/Makefile.am
+++ b/conformance/Makefile.am
@@ -268,10 +268,10 @@ test_ruby: protoc_middleman conformance-test-runner $(other_language_protoc_outp
# These depend on library paths being properly set up. The easiest way to
# run them is to just use "tox" from the python dir.
test_python: protoc_middleman conformance-test-runner
- ./conformance-test-runner --failure_list failure_list_python.txt $(CONFORMANCE_PYTHON_EXTRA_FAILURES) ./conformance_python.py
+ ./conformance-test-runner --failure_list failure_list_python.txt ./conformance_python.py
test_python_cpp: protoc_middleman conformance-test-runner
- ./conformance-test-runner --failure_list failure_list_python_cpp.txt $(CONFORMANCE_PYTHON_EXTRA_FAILURES) ./conformance_python.py
+ ./conformance-test-runner --failure_list failure_list_python_cpp.txt ./conformance_python.py
if OBJC_CONFORMANCE_TEST