aboutsummaryrefslogtreecommitdiffhomepage
path: root/conformance/Makefile.am
diff options
context:
space:
mode:
authorGravatar Thomas Van Lenten <thomasvl@google.com>2015-12-02 11:48:14 -0500
committerGravatar Thomas Van Lenten <thomasvl@google.com>2015-12-02 11:48:14 -0500
commit69d713fc3c941c9f266358c4fb12c8c2bc5d1c85 (patch)
tree87bd108c0130abc5bfb68ac3b39b67088cb31e8c /conformance/Makefile.am
parente4af879ba24f73379f6efc52d8d7e0154ad2ce2e (diff)
Ensure the conformance build of objc code is using the Mac OS X SDK and
Diffstat (limited to 'conformance/Makefile.am')
-rw-r--r--conformance/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/conformance/Makefile.am b/conformance/Makefile.am
index d7bb9397..ea5edbba 100644
--- a/conformance/Makefile.am
+++ b/conformance/Makefile.am
@@ -38,7 +38,11 @@ bin_PROGRAMS += conformance-objc
conformance_objc_SOURCES = conformance_objc.m ../objectivec/GPBProtocolBuffers.m
nodist_conformance_objc_SOURCES = Conformance.pbobjc.m
-conformance_objc_CPPFLAGS = -I$(top_srcdir)/objectivec
+# On travis, the build fails without the isysroot because whatever system
+# headers are being found don't include generics support for
+# NSArray/NSDictionary, the only guess is their image at one time had an odd
+# setup for Xcode and old frameworks are being found.
+conformance_objc_CPPFLAGS = -I$(top_srcdir)/objectivec -isysroot `xcrun --sdk macosx --show-sdk-path`
conformance_objc_LDFLAGS = -framework Foundation
# Explicit dep beacuse BUILT_SOURCES are only done before a "make all/check"
# so a direct "make test_objc" could fail if parallel enough.