aboutsummaryrefslogtreecommitdiffhomepage
path: root/conformance/Makefile.am
diff options
context:
space:
mode:
authorGravatar Thomas Van Lenten <thomasvl@google.com>2015-11-16 11:24:58 -0500
committerGravatar Thomas Van Lenten <thomasvl@google.com>2015-11-16 11:29:59 -0500
commit42f2eee932fe595671bc9d9eb0680038b03cdfe3 (patch)
treebbdc7211194132a15cb23f20c406687155ec6bcd /conformance/Makefile.am
parent8b31d7410aabefc2e93f85e13f44846ddfa0f135 (diff)
Cleanups of deps and ignores for conformance
- Hopefully complete the deps for other languages for the generated conformance proto sources. - List the generated sources for cleanup by make's clean rules. - Make the toplevel nuke the pyc files that can get created in the ObjC dir.
Diffstat (limited to 'conformance/Makefile.am')
-rw-r--r--conformance/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/conformance/Makefile.am b/conformance/Makefile.am
index c74eb1c8..b6fda2a8 100644
--- a/conformance/Makefile.am
+++ b/conformance/Makefile.am
@@ -7,6 +7,10 @@ protoc_outputs = \
conformance.pb.cc \
conformance.pb.h
+other_language_protoc_outputs = \
+ conformance.rb \
+ com/google/protobuf/conformance/Conformance.java
+
bin_PROGRAMS = conformance-test-runner conformance-cpp
conformance_test_runner_LDADD = $(top_srcdir)/src/libprotobuf.la
@@ -38,14 +42,16 @@ endif
$(protoc_outputs): protoc_middleman
+$(other_language_protoc_outputs): protoc_middleman
+
BUILT_SOURCES = $(protoc_outputs)
-CLEANFILES = $(protoc_outputs) protoc_middleman javac_middleman conformance-java conformance-csharp
+CLEANFILES = $(protoc_outputs) protoc_middleman javac_middleman conformance-java conformance-csharp $(other_language_protoc_outputs)
MAINTAINERCLEANFILES = \
Makefile.in
-javac_middleman: ConformanceJava.java protoc_middleman
+javac_middleman: ConformanceJava.java protoc_middleman $(other_language_protoc_outputs)
javac -classpath ../java/target/classes ConformanceJava.java com/google/protobuf/conformance/Conformance.java
@touch javac_middleman
@@ -58,7 +64,7 @@ conformance-java: javac_middleman
# Currently the conformance code is alongside the rest of the C#
# source, as it's easier to maintain there. We assume we've already
# built that, so we just need a script to run it.
-conformance-csharp:
+conformance-csharp: $(other_language_protoc_outputs)
@echo "Writing shortcut script conformance-csharp..."
@echo '#! /bin/sh' > conformance-csharp
@echo 'mono ../csharp/src/Google.Protobuf.Conformance/bin/Release/Google.Protobuf.Conformance.exe "$$@"' >> conformance-csharp
@@ -74,5 +80,5 @@ test_java: protoc_middleman conformance-test-runner conformance-java
test_csharp: protoc_middleman conformance-test-runner conformance-csharp
./conformance-test-runner --failure_list failure_list_csharp.txt ./conformance-csharp
-test_ruby: protoc_middleman conformance-test-runner
+test_ruby: protoc_middleman conformance-test-runner $(other_language_protoc_outputs)
RUBYLIB=../ruby/lib:. ./conformance-test-runner --failure_list failure_list_ruby.txt ./conformance_ruby.rb