aboutsummaryrefslogtreecommitdiffhomepage
path: root/conformance/Makefile.am
diff options
context:
space:
mode:
authorGravatar Yilun Chong <yilunchong@google.com>2017-07-05 09:51:58 -0700
committerGravatar Yilun Chong <yilunchong@google.com>2017-07-05 09:51:58 -0700
commit30b4194488d37019aaf88f199aa447cd55c74c60 (patch)
treebb2ec0521516e6c4f950c8382655bcaef1dd2e2e /conformance/Makefile.am
parent7339c25d120246d711486f458cd098a94f8b2455 (diff)
parente82ba0b8026eb16c40ceba861f02c643c36e8232 (diff)
Merge branch 'ConformanceTestYilunChong' of github.com:BSBandme/protobuf into ConformanceTestYilunChong
Diffstat (limited to 'conformance/Makefile.am')
-rw-r--r--conformance/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/conformance/Makefile.am b/conformance/Makefile.am
index 58eb7f59..dcd1714c 100644
--- a/conformance/Makefile.am
+++ b/conformance/Makefile.am
@@ -315,7 +315,7 @@ conformance-csharp: $(other_language_protoc_outputs)
conformance-php:
@echo "Writing shortcut script conformance-php..."
@echo '#! /bin/sh' > conformance-php
- @echo 'php ./conformance_php.php' >> conformance-php
+ @echo 'php -d auto_prepend_file=autoload.php ./conformance_php.php' >> conformance-php
@chmod +x conformance-php
conformance-php-c:
@@ -346,6 +346,9 @@ test_php: protoc_middleman conformance-test-runner conformance-php $(other_langu
test_php_c: protoc_middleman conformance-test-runner conformance-php-c $(other_language_protoc_outputs)
./conformance-test-runner --enforce_recommended --failure_list failure_list_php_c.txt ./conformance-php-c
+test_php_zts_c: protoc_middleman conformance-test-runner conformance-php-c $(other_language_protoc_outputs)
+ ./conformance-test-runner --enforce_recommended --failure_list failure_list_php_zts_c.txt ./conformance-php-c
+
# These depend on library paths being properly set up. The easiest way to
# run them is to just use "tox" from the python dir.
test_python: protoc_middleman conformance-test-runner