aboutsummaryrefslogtreecommitdiffhomepage
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Feng Xiao <xfxyjwf@gmail.com>2015-06-05 17:59:09 -0700
committerGravatar Feng Xiao <xfxyjwf@gmail.com>2015-06-05 23:36:05 -0700
commitdffd542bb8d45f6846a65864a39674669915fce6 (patch)
tree655fea2ccef1ccdc6f5dd7d3b9b31b521afe267e /cmake/CMakeLists.txt
parente9839ff444dc932cfc5578eaf00f7c80a927a4dc (diff)
Update ./update_file_lists.sh.
Make it executable and generate extract_includes.bat in the same directory.
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index e8d670c9..727864ba 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -47,6 +47,11 @@ include(find_hash_map.cmake)
configure_file(config.h.in config.h)
configure_file(pbconfig.h.in google/protobuf/stubs/pbconfig.h)
+if (MSVC)
+ string(REPLACE "/" "\\" PROTOBUF_SOURCE_WIN32_PATH ${protobuf_SOURCE_DIR})
+ string(REPLACE "/" "\\" PROTOBUF_BINARY_WIN32_PATH ${protobuf_BINARY_DIR})
+ configure_file(extract_includes.bat.in extract_includes.bat)
+endif (MSVC)
get_filename_component(protobuf_source_dir ${protobuf_SOURCE_DIR} PATH)