aboutsummaryrefslogtreecommitdiffhomepage
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Konstantin Podsvirov <konstantin@podsvirov.pro>2015-09-01 16:44:48 +0300
committerGravatar Konstantin Podsvirov <konstantin@podsvirov.pro>2015-09-01 16:44:48 +0300
commit905f46403582ca2c43e1ad249dd01fa97191c4d0 (patch)
treee4e59b71deb095b858c955b0cd66dcdc9ca25d87 /cmake/CMakeLists.txt
parentd79e0379f2a600fa22d007e3a74149c6c541a09a (diff)
Using NEW behavior for CMP0022 in CMake project
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index a9acf7e6..6a4ec2f4 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -4,6 +4,9 @@ cmake_minimum_required(VERSION 2.8)
# Project
project(protobuf C CXX)
+# CMake policies
+cmake_policy(SET CMP0022 NEW)
+
# Options
option(protobuf_VERBOSE "Enable for verbose output" OFF)
option(BUILD_TESTING "Build tests" ON)