aboutsummaryrefslogtreecommitdiffhomepage
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Konstantin Podsvirov <konstantin@podsvirov.pro>2015-09-15 15:30:02 +0300
committerGravatar Konstantin Podsvirov <konstantin@podsvirov.pro>2015-09-15 15:30:02 +0300
commit673d32e0930bd87536da71b3bf1d0c6c3d098833 (patch)
tree6e74d4ef76fe6a384fa31150482be7a103cb2798 /cmake/CMakeLists.txt
parent2fa0439b0074c61d48fa6120d0734ae8c1e5debb (diff)
Rename CMake option BUILD_TESTING to protobuf_BUILD_TESTS
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 6a4ec2f4..50e60f34 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -9,7 +9,7 @@ cmake_policy(SET CMP0022 NEW)
# Options
option(protobuf_VERBOSE "Enable for verbose output" OFF)
-option(BUILD_TESTING "Build tests" ON)
+option(protobuf_BUILD_TESTS "Build tests" ON)
option(BUILD_SHARED_LIBS "Build Shared Libraries" OFF)
option(protobuf_MSVC_STATIC_RUNTIME "Link static runtime libraries" ON)
if (MSVC)
@@ -136,8 +136,8 @@ include(libprotobuf.cmake)
include(libprotoc.cmake)
include(protoc.cmake)
-if (BUILD_TESTING)
+if (protobuf_BUILD_TESTS)
include(tests.cmake)
-endif (BUILD_TESTING)
+endif (protobuf_BUILD_TESTS)
include(install.cmake)