aboutsummaryrefslogtreecommitdiffhomepage
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Wei-Yin Chen (陳威尹) <wychen@chromium.org>2016-08-19 15:25:54 -0700
committerGravatar Wei-Yin Chen (陳威尹) <wychen@chromium.org>2016-08-31 17:28:51 -0700
commit588a803d586447582b8398a92c3d93808f80e285 (patch)
treef6155be17ab2bfc9e4d0b901d9c0456be70a9f55 /cmake/CMakeLists.txt
parentb9649765f8e5c85523c138ac990a7523a54bfdbe (diff)
Support Unicode build on Windows
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index f947b741..8c374b7e 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -159,6 +159,10 @@ else (MSVC)
set(LIB_PREFIX)
endif (MSVC)
+if (UNICODE)
+ add_definitions(-DUNICODE -D_UNICODE)
+endif (UNICODE)
+
include(libprotobuf-lite.cmake)
include(libprotobuf.cmake)
include(libprotoc.cmake)