aboutsummaryrefslogtreecommitdiffhomepage
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Wojciech Mamrak <wmamrak@gmail.com>2017-02-18 15:44:29 +0100
committerGravatar GitHub <noreply@github.com>2017-02-18 15:44:29 +0100
commit37bd5d525b5caf8418e33591aff1613ac45034db (patch)
treea5483d8f3d5e32b27226b00e1feddc63801c703a /cmake/CMakeLists.txt
parenta9ab38c17178fcedd9b46c09fa33f94d1a6335c3 (diff)
Disable MSVC warning C4309
> warning C4309: static_cast': truncation of constant value introduced in commit 9db5b11c9cf2922435b53495b9c1e114525f0428
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index df3b2012..7618ba21 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -135,7 +135,7 @@ endif (protobuf_BUILD_SHARED_LIBS)
if (MSVC)
# Build with multiple processes
add_definitions(/MP)
- add_definitions(/wd4244 /wd4267 /wd4018 /wd4355 /wd4800 /wd4251 /wd4996 /wd4146 /wd4305)
+ add_definitions(/wd4244 /wd4267 /wd4018 /wd4355 /wd4800 /wd4251 /wd4996 /wd4146 /wd4305 /wd4309)
# Allow big object
add_definitions(/bigobj)
string(REPLACE "/" "\\" PROTOBUF_SOURCE_WIN32_PATH ${protobuf_SOURCE_DIR})