aboutsummaryrefslogtreecommitdiffhomepage
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Feng Xiao <xfxyjwf@gmail.com>2015-06-04 01:27:19 -0700
committerGravatar Feng Xiao <xfxyjwf@gmail.com>2015-06-04 01:27:19 -0700
commit34448fca45b64e084db54ad3cc623b8bfe8b3863 (patch)
tree57d392e52c3c0805cf63d16d043e0c8d8a51a2a4 /cmake/CMakeLists.txt
parent4333edb34048d29a410cc247ff7ffbad8145132f (diff)
Add an cmake option to exclude tests.
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 146ea780..02bba4c9 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -2,6 +2,7 @@ cmake_minimum_required(VERSION 2.8)
project(protobuf C CXX)
+option(BUILD_TESTING "Build tests" ON)
option(BUILD_SHARED_LIBS "Build Shared Libraries" OFF)
if (MSVC)
option(ZLIB "Build with zlib support" OFF)
@@ -66,5 +67,6 @@ endif (MSVC)
include(libprotobuf-lite.cmake)
include(libprotobuf.cmake)
include(libprotoc.cmake)
-include(protoc.cmake)
-include(tests.cmake)
+if (BUILD_TESTING)
+ include(protoc.cmake)
+endif (BUILD_TESTING)