aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Adam Cozzette <acozzette@google.com>2017-03-08 11:25:48 -0800
committerGravatar Adam Cozzette <acozzette@google.com>2017-03-09 10:03:22 -0800
commit9fa40314fcfd19d2e09459faeb480d213af56324 (patch)
tree363b97e8e92cadcd578ade2c53af25f7bf4f7b3a /Makefile.am
parent2b7430d96aeff2bb624c8d52182ff5e4b9f7f18a (diff)
Ruby: wrap calls to memcpy so that gem is compatible with pre-2.14 glibc
This commit adds a __wrap_memcpy function and a linker flag to use that in place of memcpy for our Ruby gem C extension. This allows us to always use the 2.2.5 version of memcpy, making it possible to use the gem on distributions with pre-2.14 versions of glibc. Before this change: $ objdump -T protobuf_c.so | grep memcpy 0000000000000000 DF *UND* 0000000000000000 GLIBC_2.3.4 __memcpy_chk 0000000000000000 DF *UND* 0000000000000000 GLIBC_2.14 memcpy After: $ objdump -T protobuf_c.so | grep memcpy 0000000000000000 DF *UND* 0000000000000000 GLIBC_2.2.5 memcpy 0000000000000000 DF *UND* 0000000000000000 GLIBC_2.3.4 __memcpy_chk 0000000000042450 g DF .text 0000000000000005 Base __wrap_memcpy This is based on gRPC's solution to a similar problem: https://github.com/grpc/grpc/blob/5098508d2d41a116113f7e333c516cd9ef34a943/src/core/lib/support/wrap_memcpy.c This fixes issue #2783.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c8f7f696..3222417f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -795,6 +795,7 @@ ruby_EXTRA_DIST= \
ruby/ext/google/protobuf_c/storage.c \
ruby/ext/google/protobuf_c/upb.c \
ruby/ext/google/protobuf_c/upb.h \
+ ruby/ext/google/protobuf_c/wrap_memcpy.c \
ruby/google-protobuf.gemspec \
ruby/lib/google/protobuf/message_exts.rb \
ruby/lib/google/protobuf/repeated_field.rb \