aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Jisi Liu <jisi.liu@gmail.com>2015-06-12 15:49:21 -0700
committerGravatar Jisi Liu <jisi.liu@gmail.com>2015-06-16 18:27:36 -0700
commit78d470c7a50d3788bf3f819eba99597aea43674f (patch)
treef2d0c53ce1a94234cc4994ea319f1560f44b2f96 /Makefile.am
parent4cbb612299eaf8259db25f5dcda46022fbd1db54 (diff)
Make the code independent of config.h
Now the Build tool needs to define -DHAVE_ZLIB and -DHAVE-PTHREAD rather than providing a config.h - Make pbconfig.h a manually written file to handle hash conditions according to platform related macros. - Remove #include "config.h" from source code. - Changed the configure.ac and Makefile.am to pass down the macros. - Change cmake to pass down the the macros. Change-Id: I537249d5df8fdeba189706aec436d1ab1104a4dc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0eb80202..8d7bb563 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -744,12 +744,9 @@ EXTRA_DIST = $(@DIST_LANG@_EXTRA_DIST) \
CONTRIBUTORS.txt \
CHANGES.txt \
cmake/CMakeLists.txt \
- cmake/config.h.in \
- cmake/find_hash_map.cmake \
cmake/libprotobuf.cmake \
cmake/libprotobuf-lite.cmake \
cmake/libprotoc.cmake \
- cmake/pbconfig.h.in \
cmake/protoc.cmake \
cmake/README.md \
cmake/tests.cmake \