aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Paul Yang <TeBoring@users.noreply.github.com>2017-12-07 14:18:38 -0800
committerGravatar GitHub <noreply@github.com>2017-12-07 14:18:38 -0800
commit0e7b58956684c7c2fc228eff9173ea2ae50de911 (patch)
treedd44fc86e270993b176a6f315fc2ac67dccda855 /Makefile.am
parentc370f88fb18eecc33650ec3ce06f7bdcc11d1596 (diff)
Add discard unknown API in ruby. (#3990)
* Add discard unknown API in ruby. * Add test for oneof message field. * Add TestUnknown to represent unknown field data clearly. * Only serialize the message with unknown fields itself in test. * Move discard_unknown from Message to Google.Protobuf
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cd1cfc3e..cba02e3d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -907,6 +907,7 @@ ruby_EXTRA_DIST= \
ruby/src/main/java/google/ProtobufJavaService.java \
ruby/src/main/sentinel.proto \
ruby/tests/basic.rb \
+ ruby/tests/encode_decode_test.rb \
ruby/tests/gc_test.rb \
ruby/tests/repeated_field_test.rb \
ruby/tests/stress.rb \