aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Joshua Haberman <jhaberman@gmail.com>2016-05-03 13:11:20 -0700
committerGravatar Joshua Haberman <jhaberman@gmail.com>2016-05-03 13:11:20 -0700
commit07bcf21a9cbe600f45cba2fe38710a4ad5f7c5bc (patch)
treeb7f4a49aa5694c4de6dbd0ca88f8b15cfd90b91d /Makefile.am
parent7dda312224b298fb857ddd791bed148d46aac94e (diff)
parent247ef1f0df4ebb08a2bd8d47912a9e42b88abdc2 (diff)
Merge pull request #1464 from google/benchmarks
Added framework for generating/consuming benchmarking data sets.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a7a1f413..3e988816 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,7 @@ AUTOMAKE_OPTIONS = foreign
SUBDIRS = . src
# Always include gmock in distributions.
-DIST_SUBDIRS = $(subdirs) src conformance
+DIST_SUBDIRS = $(subdirs) src conformance benchmarks
# Build gmock before we build protobuf tests. We don't add gmock to SUBDIRS
# because then "make check" would also build and run all of gmock's own tests,
@@ -36,6 +36,10 @@ clean-local:
echo "Making clean in conformance"; \
cd conformance && $(MAKE) $(AM_MAKEFLAGS) clean; \
fi; \
+ if test -e benchmarks/Makefile; then \
+ echo "Making clean in benchmarks"; \
+ cd benchmarks && $(MAKE) $(AM_MAKEFLAGS) clean; \
+ fi; \
if test -e objectivec/DevTools; then \
echo "Cleaning any ObjC pyc files"; \
rm -f objectivec/DevTools/*.pyc; \