aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..d5f4ab2
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,35 @@
+# Makefile.am -- automake script for ppamltracer
+# Copyright (C) 2013 Galois, Inc.
+#
+# This program is free software: you can redistribute it and/or modify it under
+# the terms of the GNU General Public License as published by the Free Software
+# Foundation, either version 3 of the License, or (at your option) any later
+# version.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
+# details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# To contact Galois, complete the Web form at <http://corp.galois.com/contact/>
+# or write to Galois, Inc., 421 Southwest 6th Avenue, Suite 300, Portland,
+# Oregon, 97204-1622.
+
+lib_LTLIBRARIES = libppamltracer.la
+libppamltracer_la_SOURCES = \
+ $(srcdir)/require.h \
+ $(srcdir)/timing.c \
+ $(srcdir)/timing.h \
+ $(srcdir)/tracer.c
+libppamltracer_la_CFLAGS = \
+ -I$(top_srcdir)/include \
+ -std=c99 \
+ -Wall \
+ -Wextra \
+ -pedantic \
+ @OTF_CFLAGS@
+libppamltracer_la_LIBADD = @OTF_LIBS@
+libppamltracer_la_LDFLAGS = -export-symbols-regex '^ppaml_'