aboutsummaryrefslogtreecommitdiff
path: root/bindings/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/python/setup.py')
-rwxr-xr-xbindings/python/setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/bindings/python/setup.py b/bindings/python/setup.py
new file mode 100755
index 0000000..d8e9ec2
--- /dev/null
+++ b/bindings/python/setup.py
@@ -0,0 +1,34 @@
+#!/usr/bin/env python
+# setup.py -- distutils setup script for ppamltracer-python
+# Copyright (C) 2013 Galois, Inc.
+#
+# This program is free software: you can redistribute it and/or modify it under
+# the terms of the GNU General Public License as published by the Free Software
+# Foundation, either version 3 of the License, or (at your option) any later
+# version.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
+# details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# To contact Galois, complete the Web form at <http://corp.galois.com/contact/>
+# or write to Galois, Inc., 421 Southwest 6th Avenue, Suite 300, Portland,
+# Oregon, 97204-1622.
+
+from distutils.core import setup
+
+setup(name="ppamltracer-python",
+ version="0.1.0",
+ description="ppamltracer Python bindings",
+ author="Benjamin Barenblat",
+ author_email="bbarenblat@galois.com",
+ classifiers=["Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: GNU General Public License (GPL)",
+ "Topic :: Software Development :: Compilers"],
+ license="GPL",
+ py_modules=['ppamltracer'])