aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbarenblat@galois.com>2014-01-27 15:15:43 -0800
committerGravatar Benjamin Barenblat <bbarenblat@galois.com>2014-01-27 15:17:06 -0800
commitbb3a3a61fe7b971ad8ef326ec7e4d5903e6860ee (patch)
tree1e7cb626e710d0cf1888ee89f45e65afb5b41a13 /test/Makefile.am
parentecdc86999a7eb30223209887801ec8bbeac1cc9e (diff)
Functional tests for C library
While gearing up to make an addition to the C library, I became concerned at the lack of test infrastructure for the project. The build system now integrates Check <http://check.sourceforge.net/>;, a lightweight testing framework for C, and there are a few tests to ensure no serious regressions occur. You can run the tests with “make check”.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..b5e30d5
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,41 @@
+# Makefile.am -- automake script for ppamltracer tests
+# Copyright (C) 2013 Galois, Inc.
+#
+# This program is free software: you can redistribute it and/or modify it under
+# the terms of the GNU General Public License as published by the Free Software
+# Foundation, either version 3 of the License, or (at your option) any later
+# version.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
+# details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# To contact Galois, complete the Web form at <http://corp.galois.com/contact/>
+# or write to Galois, Inc., 421 Southwest 6th Avenue, Suite 300, Portland,
+# Oregon, 97204-1622.
+
+TESTS = check_ppamltracer
+check_PROGRAMS = check_ppamltracer
+check_ppamltracer_SOURCES = \
+ check_ppamltracer.c \
+ tmpdir.c \
+ tmpdir.h \
+ trace_invalid.c \
+ trace_invalid.h \
+ trace_valid.c \
+ trace_valid.h
+check_ppamltracer_CFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src \
+ -std=c99 \
+ -Wall \
+ -Wextra \
+ -pedantic \
+ @check_CFLAGS@
+check_ppamltracer_LDADD = \
+ $(top_builddir)/src/libppamltracer.la \
+ @check_LIBS@