aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbarenblat@galois.com>2014-03-04 16:23:30 -0800
committerGravatar Benjamin Barenblat <bbarenblat@galois.com>2014-03-04 16:24:21 -0800
commitc1bf51b8e23c9f2d8d3147fe259a77b8f202e71a (patch)
tree8933e46995dfba3f2022656c3873fc7857b083c9 /configure.ac
parentdf0ab6ea1b788c682e3a2afa8ab4672f27504e94 (diff)
Tell Windows users to build with '--disable-shared'
As detailed in GitHub issue #1, attempting to build ppamltracer as a shared library on Cygwin fails. I believed commit bfc92ba (‘autotools: Don’t build DLLs on Cygwin by default’) fixed this; it does, but it also disables shared library building on non-Cygwin systems. We need to do a release, so this bug is getting deferred until later; for the time being, the documented workaround is to pass '--disable-shared' to 'configure'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 3933d8b..8b3ce7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,6 @@
# Fire up Autoconf.
AC_PREREQ([2.69])
AC_INIT([ppamltracer], [0.1.0], [bbarenblat@galois.com])
-AC_CANONICAL_TARGET
# Fire up Automake. Use ustar format because we actually have file names
# longer than 99 characters (hooray, Java).
@@ -32,19 +31,13 @@ AC_CONFIG_MACRO_DIR([m4])
# Build quietly.
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-# Build C.
+# Build a C library.
AC_CONFIG_SRCDIR([config.h.in])
AC_CONFIG_HEADERS([config.h])
AC_PROG_CC
AC_PROG_CC_C99
# Automake 1.12 seems to require this, but automake 1.11 doesn't recognize it.
m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
-
-# Build a library. On Cygwin, libotf does not build DLLs, so make ppamltracer
-# also not build DLLs.
-if test "$target_os" = "cygwin"; then
- AC_DISABLE_SHARED
-fi
LT_INIT
# Dependencies